HDMI audio output with boom2

edited July 2015 in Boom Discussions
Hi there

When connecting the HDMI the audio does not go to this output and keep jumping to Boom2Device on the sound settings preferences from Mac, so the audio keep it self on the mac and not on the TV connected to the HDMI port, the only solution is to shutdown Boom from mac and then it works....

This should be working fine like when the headphones are connected or the mac speakers with boom2 working... so when connecting to HDMI audio should be processed by boom2 going to the HDMI output.

If you see the screenshot attached there is an HDMI audio output, well, when selecting this one no audio goes to it if boom2 is on, so I have to shut it down in order to have audio on the HDMI output which is a Samsung TV.

When selecting headphones these work normally with boom2 on.

Boom 2:

Version: 1.2.1
Source: 3rd Party
Install Date: 01/07/15 10:27

Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro11,3
Processor Name: Intel Core i7
Processor Speed: 2,8 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 16 GB
Boot ROM Version: MBP112.0138.B15
SMC Version (system): 2.19f12

System Software Overview:

System Version: OS X 10.10.4 (14E46)
Kernel Version: Darwin 14.4.0
Boot Volume: Macintosh HD
Boot Mode: Normal


  • Hey,

    Could you please make sure that you have selected the HDMI option in the System Preferences for Sound and check if it helps. Also, make sure that mute option is unchecked for both Boom2Device and HDMI in the same.

    Next, launch the audio MIDI Setup app and see whether the mute option is checked for Boom2Device for both Input and Output Preferences. (see the screenshot below)
    If yes, uncheck the same and see whether it helps.

  • edited August 2015
    Same problem here. The only way to switch audio to HDMI is to quit boom app. Otherwise it just keeps jumping back to Boom2 device when I try to select HDMI.
Sign In or Register to comment.