Voila is slowing down my wifi connection

edited July 2015 in Voila Discussions
I can't seem to find anyone else that has posted this issue, but I have spent a lot of time debugging the problem and there is no doubt that the Voila application is slowing down my internet. I am on version 3.9 and Yosemite.

I noticed my wifi was not reaching the 30 mbps that every other device in the house was able to get and it would get slower and slower as the day went on. I even took my Macbook into the Apple store thinking it was a hardware issue. The first thing they did was shut down all my applications and it worked perfectly fine, reaching 50 mbps in the store. I thought maybe I was just crazy. Wifi still worked great when I got home after that, but then I started up my usual applications and could not get my wifi to go over 20 mbps again. It became very obvious at that point what the problem was and I was easily able to recreate the issue by closing and opening Viola and testing on the speedtest site. I don't even have to take a screenshot or do anything and it instantly slows it down.

What is even more baffling is that I can't find any reason why the program is even trying to use the internet at all. Here are all the things I've tried:
-I have no sharing configured in the app (nor did I ever have that setup).
-I deleted my entire screenshot history.
-I moved the library location to a different folder, in case iCloud was picking it up under Photos.
-I blocked the Viola app in my firewall settings.
-I disabled AirDrop.

I've watched the network activity monitor while running the speed test and I don't see anything unusual going on there either. If I wasn't able to reproduce it over and over, I would just write it off as a fluke. I used to leave Viola open all day long, but now my only resolution is to keep it closed and only launch it when I need to take a screenshot.

I can't possibly be the only person with this issue, am I? The only reason I even bothered to start obsessively checking my internet speed was because I upgraded my service and wanted to make sure I was getting the speed I'm paying for. I'm not sure I would have even noticed the issue otherwise.

I am really hoping the developers see this and have an idea what might be wrong so they can fix it. Of all the applications I'd have blamed for messing with my internet, I would have never expected it to be the only app I use that doesn't need the internet at all. Fix it please!!


  • Hi Jemerson76,

    So far in Voila we have not come across such issue with internet connection. But, we did notice the issue in Boom 2 update v1.2. We did fix the issue with a follow-up update in Boom 2 v1.2.1.
    Do you use Boom 2? If so, could you please update your copy of Boom 2 to the latest version and check if it helps.
    Also, we did check with the speedtest site and did not see any changes. If you do, could you please send us few screenshots of the issue?
    You can always get in touch with our Support Team (voila@globaldelight.com) for further help.
  • No, I don't use Boom 2. I will send the screenshots to the support email. Thanks!
This discussion has been closed.