Discussions and Audio Problem

edited March 2011 in Voila Discussions
I can't get audio from video recording. I tried the various settings, even tried going to my computer's preferences and changed the Sound Output choices. I installed the Soundflower and even those choices don't work. I used to use Snapz Pro and it's video recording audio works.

I read the FAQs and followed the steps to get audio, but no go. I'm curious, what sound output do you use on your Mac? I use the headphone output since I have external speakers plugged in. Does Voila not work with external speakers? Hopefully it does, because it would be a pain to have to unplug my speakers to record video with audio.

Also, when viewing the Discussions in Google Chrome for Mac, I see a list of discussions sorted by date. But when I click on one, nothing happens. It did let me create a new discussion however, I'm sorry if there was already a discussion about audio problems.

Comments

  • Hi tcdriver,

    Could you tell us what content were you trying to record? When recording a video from YouTube, a website, or a movie player, you must only keep the 'Record Computer Audio' selected.

    Steps:

    1) Launch the site or the movie player that you want to capture the video from
    2) Launch Voila, select the mode of Screen Recording that you want. I have chosen Selection capture here. Choose the area that you want to capture
    3) Since you are recording audio from a website/player, keep only the "Record Computer Audio" option selected. Hit the record button
    4) Start the video/audio file on the website/player. Recording in progress. Once done, select the "Stop and Save Recording" from the menu bar
    5) Now playback the video in Voila

    You can also watch the small movie file on how to do it, below:

    http://www.globaldelight.com/gdtplforum/voila_capture.mov

    If you are still unable to hear/capture the audio or are trying to record a video of your desktop, please mention the input device that you are using to record the audio, and the options that you have selected in the recording panel.

    Using an external speaker or a headphone, is not an issue in Voila.
  • Thanks for the quick reply. I'm closer to the solution.

    I had success in recording web videos!

    Next I tried recording an .avi file playing in the VLC app. For input I have 4 choices: Line In, Display Audio (Apple Cinema Display), and 2 types of Soundflower. There was sound with Line In, but it was horrible. Display Audio was better, but it sounded like it was coming from a tin can. Soundflowers did nothing.

    Do I have to plug in an external microphone to record movie files playing in a movie player? What do you use?

    Thanks for your help!
  • While recording video from a video player, you must follow the same steps as while capturing a web video.

    The Computer Audio is recorded in both the cases.
  • Hi, I am all of a sudden having the same problem: sound isn't being recorded with my video, for example when I try to record something from a web site. This worked literally a few days ago, so I must have changed settings somewhere.

    To follow through your steps, adding my comments:

    Steps:

    1) Launch the site or the movie player that you want to capture the video from
    2) Launch Voila, select the mode of Screen Recording that you want. I have chosen Selection capture here. Choose the area that you want to capture
    [I used Selection, as well]
    3) Since you are recording audio from a website/player, keep only the "Record Computer Audio" option selected. Hit the record button
    [Done: selected only "Record Computer Audio" and "Allow Cursor while recording"]
    4) Start the video/audio file on the website/player. Recording in progress. Once done, select the "Stop and Save Recording" from the menu bar
    [The instant I start recording, the audio from the site disappears: I no longer hear it from the computer speakers or through headphones. The instant I stop recording, the audio comes back.]
    5) Now playback the video in Voila
    [I do, and there's no audio there]

    I'm baffled by this: this used to work, very recently! I used to select "Audio from: Soundflower (16ch)" as well as "Record computer audio", not having seen the advice against doing that, but now that doesn't work either! There seems to be nothing I can do to get sound with the video, and it's frustrating.

    Have there been any changes or updates that might explain the recent apparent change in my ability to record audio? This used to work like a charm, every time, and so far I can't see what happened to change it ...
  • Some additional specs, I guess, in case these help:

    Voila 3.1
    OS 10.6.8
    Soundflower 1.5.2
  • Hi DaveMc

    Voila records sound through Sound flower. Could you please uninstall sound flower using the following uninstall command. First open "Terminal" in Spotlight, copy "sudo kextunload /System/Library/Extensions/Soundflower.kext/ " and paste it in terminal window and press enter. Make sure to check the system sound preference whether you still find sound flower(if yes then try again giving the same command) Next quit and launch Voila. Go to record in Voila and select full-screen record and un-check and check "Record computer audio" , it will ask for sound flower installation. Install.

    Also go to System Sound Preferences and change the volume bar in Sound flower (2ch). Voila records the audio from Sound flower (2ch). We suggest you to use Sound flower directed by Voila i.e Sound flower v1.5.1.
  • That worked! Thanks so much for your help.
Sign In or Register to comment.