after installation, it warns that there's no internet connection, and there is

Macbook Pro 10.10.3 Yosemite.
I've had boom 2 working before and now it's telling me that it can't connect to the internet. I have no third party things running. I have internet connection. I think there was a firmware update recently that i did, not sure when though.
I have a registration number, and have tried uninstalling it and downloading a new copy and still same error.
I have not blocked outbound access to GlobalDelight, I have set the privacy/security to allow boom 2 to access the outside world.
Any ideas would be appreciated,. Thanks


  • Ok, It's working fine now....I'm not sure what changed, but I did change the security and privacy settings to :"allow apps downloaded from" ANYWHERE. Then I restarted BOOM2 and THEN was told that there's an update available, I installed it, and then put the "allow apps" thing back to MacApp Store only, and it all seems to be working again.

    I don't know offhand what version I'd tried before, I thought it was the most up to date, since I;d just downloaded it again....I could start up from a Carbon Copy Cloner copy and see what the old one was, but for now, the internet connection needed is apparently working. And I'm just plain lazy.

  • I wonder why we are not getting any responses from the Gurus?
  • Hi Jonkip,

    Good to know that it works fine now!
  • I have the same problem -- getting a message that says no Internet connection. This problem was reported more than a year ago. What gives?
  • edited November 2015
    Hi Ness,

    Could you please try registering the app again and check if it helps. Sometimes, due to  minor error in the server, user face such issue with the app. Kindly try registering the app again and check if it helps.
Sign In or Register to comment.