Window Snapping Shadow issues...Ability to not set a HOTKEY.

edited March 2013 in Voila Discussions
1. Will there ever be an option to NOT capture a window/objects drop-shadow? Not having this option seriously impedes Viola from becoming the killer screen capture app.

2. Ability to not set a HOT KEY, turn off access to a Voila function that is not used. Example: clashing keyboard commands especially when capturing within Adobe CS programs. Can there be a check mark column to toggle on/off the features we would like not have a HOT KEY and simply activate said feature from the dropdown menu?


  • Hey there,

    Regarding your query, in object capture, shadow is captured. You can do a selection capture where shadow will not be captured.
    We have considered your suggestion and a feature request has been logged about turning off the shadow in object capture. Our development team will be notified about the same.
    We do believe that Voila needs a lot of change to be appropriate for the new era of Mac apps. We are planning to revamp Voila soon.
    If you have any other suggestion or feature request for Voila then please do let us know.

    You can change the HotKey under Voila preferences and check whether it helps.
    Could you please open Voila preference and go to -> Hot Keys -> and assign different set of key word combination for Menu capture.
    Please make sure that you check "Override system defaults" in order to not to loose the custom shortcut keys.
    To assign HotKey, double click on the keys and enter the desired HotKey (please refer screenshot below).
    After assigning the key, you do not have to hit enter to keep the changes, select any other HotKeys and the changes will be done.
  • edited March 2013
    @esagustin, I had the same issue with wanting to to leave the helper in the menu bar but wanting to delete the shortcuts because they interfere with other programs. I found they can be deleted if the preference file (in ~/Library/Preferences/com.globaldelight.Voila.plist) is opened with XCode. The shortcut keys are in Root->HotKeysValues. There's an entry for each of the helper menu bar items which then contains the shortcut. I deleted all of the shortcut values (but left the entry itself) and saved the file. Voila seems to work fine. Probably wise to backup the file first and, if you do have problems, restore the backup.

    To the dev: I really hope you'll consider making it possible to delete the hotkeys from within the preferences. Many of users don't want them but would still like to leave the helper running for convenience.

    EDIT: It seems the shortcuts may not always be released by Voila as I'm now getting more of the annoying conflicts that drove me to test this solution. I hope the developer will consider removing them.
  • Hi Mlgill,

    Regarding your query, consider your suggestions noted.
    We will pass the feature request to our development team.
  • Sorry for the really long absence in responding.

    @mlgill, Your suggestion to remove the shortcut value from .plist worked like a charm. My issue with shortcut keys interfering with other more valuable program shortcuts is now eliminated. I do not use Voila to record...and having to accidentally invoke this while within Photoshop became such a pain in the ass I stopped using and suggesting Voila for production use. I can only imagine this feature to control shortcuts will be added into Voila soon.

    @admin, Thanks for responding with a detailed understanding to this 'drop shadow' issue when snapping windows. I use a competing program (Little Snapper) which allows you to toggle the shadow on and off (life saver when compositing for web prototypes) but primarily use Voila for commenting and marking up. Where you lack in shadow control...Little Snapper lacks badly in the commenting and effect tools. Please lets see a fix for this soon.
This discussion has been closed.