Boom 2 creates static over time

edited June 2015 in Boom Discussions
For some reason when I use Boom 2, after awhile it starts to get a little static. Then if I let it go long enough the static becomes unbearable and you can barely hear the actual content. At this point I Quit Boom and re-open it and it will work again. It hasn't been a big enough problem for me to mention anything, but I was bored today so figured why not lol. Any ideas? I am up to date, and its not the speaker system because the static will happen through multiple outputs.


  • Sorry, I lied. Quitting and reopening doesn't fix it, it is only temporarily fixed when I restart the computer.
  • Hey,

    We have certain questions about the issue and we need you to help us in this.

    1. Does the sound gets static the moment you launch Boom 2 or after few minutes/seconds after the launch?

    2. The issue is with the Mac internal speakers or any other connected headset/speakers. If its with connected speakers/headset, then please send us the details of it.

    3. Please send us a screenshot of Boom 2 window when the sound statics.

    4. Also, check whether the issue is with the Boom 2 Volume Booster or the Equaliser or the Effects.
    When the issue occurs turn off either of the three and check whether sound statics.

    5. If the issue is with the Equaliser or the Effects, then please let us know the name of particular preset and the effect that you have selected.

    6. Please let us know the type of music you play when the issue occurs.

    7. Lastly, please send us a screenshot of the audio MIDI setup app for Boom2Device and also for any other connected devices. (similar to the attached screenshot)
  • I've been having the same issue. Toggling "boom volume" temporarily resets the issue. This has been my "quick fix" since I installed Boom 2 and the issue started.

    1. It happens after a period of time (haven't tracked to see if it's exactly the same length of time, but it happens consistently).

    2. Happens on MBP internal speakers, headphones and connected speakers (I'll connect my monitors via USB to see if it happens to those as well).

    3. Screenshot: (happens with any EQ setting).

    4. Haven't tried with Effects off, will try that this afternoon. I've also just turned off Boom Remote, will see if that has an affect.

    5. Will test this and report back later.

    6. Happens system wide (Spotify, iTunes, VLC, Netflix, etc)

    7. MIDI setup:
  • Okay, some testing updates:

    1. Happens after inconsistent timeframe (10-20 min).

    2. Does not happen via USB driven speakers.

    3. see previous

    4 & 5. Happens with Volume Booster, Equaliser and the Effects, regardless of setting.
  • Hey,

    Thank you for the info provided. We have noted down this issue and notified to our development team about the same.
  • Similar issue here. Boom 2 static/scratchy on start up of any audio source. Toggle ambiance and fidelity to get it to once again become clear.
  • Changed format to 44100hz from 96000hz on both input and output, and it works fine now. Wow!
  • Same problem here. I agree with @tenashus1: the sampling rate seems to be the problem. It only happens with my Geekout V2 USB amp where the output sampling rate is set at 384k. When I used my Macbook internal audio @ 44k no problem. (Fidelity filter enabled).
  • Hey,

    Our development team is working on a fix for the static sound issue.
    We hope to provide a fix soon.
  • Hi

    Any update on this issue? I have been having the same problem for months now, so much so that I stopped using Boom altogether as it is ruining my listening experience.

    I find that it happens a lot when media players switch form one track to another, or I switch between audio sources in tabs in a browser, etc.

    Any update would be appreciated as Boom is not reliably usable for me currently.


  • Any update on this? Latest update to Boom hasn't resolved the issue.
Sign In or Register to comment.