Voila error code

edited March 2012 in Voila Discussions
Yo guys. I recently bought Voila. I have the latest 21,5 inches iMac with the latest version of os x installed. When trying to record my screen I keep getting the following error message: An unknown error has occurred while recording the video and the file cannot be saved to the disk(error code:-1). Any1 else having the same problem? Can I resolve this issue somehow? Thanks in advance!


  • Hi Jhrlund,

    Could you please check whether you have given permissions to the disk where Voila library is selected (to do so, select the disk and do a cmd+i).

    If you are still getting the same error then could you please delete/move Voila library and create a new one, before doing so make sure that you back up the data in Voila library.

    To find Voila library>Voila preference>under General>Voila library location

    Voila library contains all the data which you worked in Voila until now.

    To view the contents or to back up data, you can do a right click on Voila library and click on "Show Package Contents" (next move the contents images/videos to a new file/folder)

    Still if you are unable to resolve then could you please write to our Support Team
  • I've been getting the same error when I try to record video using the default settings:
    - capture format: JPEG
    - audio: from built-in microphone

    When configured Voila not to record any audio it was able to record and save to disk, but would crash every time I tried to export to QuickTime. I then configured the format for video recording to H.264 and was able to capture video and export to QuickTime, but only without any sound capture or if I capture using the built-in input instead.

    Here are my system specs:

    13-inch, Aluminum, Late 2008
    Processor 2 GHz Intel Core 2 Duo
    Memory 8 GB 1067 MHz DDR3
    Graphics NVIDIA GeForce 9400M 256 MB
    Software Mac OS X Lion 10.7.5 (11G63)
    Voila version: 3.3
  • Same problem here (MacBook Pro 15 inch - late 2011 model). Video capture without sound is fine but if you try to capture with the built-in mike you get that error. No permissions problems as far as the Voila library file goes
  • edited November 2012

    Regarding your query, if you are mentioning about the error message "An unknown error has occurred while recording the video and the file cannot be saved to the disk(error code:-1)", we would like to inform you that, recently few users have reported the same issue as mentioned above. The user was using a iSight/USB to record 'Audio from'. Once removed, the issue was resolved.

    We have noticed the issue and our developers have been notified about the same. 

    In the meantime, as an alternate, you can make few change in the settings under 'Audio MIDI Setup' and check whether it helps.

    To do so, please open Audio MIDI Setup->select the active USB device->Change the sampling frequency into 16000.0Hz from 32 or any other range if options provided and let us know if it helps.

    Please make sure sure to quit and relaunch Voila after the changes in Audio MIDI Setup has been done.

    Regarding sound issue, Voila records the audio from Sound flower (2ch)
    Please uninstall and reinstall a fresh copy of Sound flower and check whether you still get the same issue. Please follow the link below to uninstall Sound flower.


    Audio MIDI Setup is a different Application -> Search via 'Spotlight'.
    Voila has compatibility issues with Bluetooth.

    Still if you have any issues, please contact our Support Team
  • Hi -
    I'm experiencing a variation of this issue. When using the internal mike, video and audio record fine. When trying to use a USB mic, I experience the error - error message: An unknown error has occurred while recording the video and the file cannot be saved to the disk(error code:-1).

    I have tried changing the sample rate in the audio midi setup, but I only have two selections - 44100.0 Hz and 48000.0 hz, both at 1ch-16bit integer. Neither selection works. Yes, I restarted Voila after making the changes in audio midi setup.

    I attempted to uninstall Sound flower (2ch), but I do not think it is installed. I cannot find is in System Settings ---> sound, it doesn't appear using spotlight, and when running the sudo command in terminal the error is "Can't open CFBundle for /System/Library/Extensions/Soundflower.kext.
    Can't create /System/Library/Extensions/Soundflower.kext."

    When I goto /System/Library/Extensions/
    Soundflower.kext is not an option.

    I'm running:
    osx 10.8.2 (12C60)
    MacBook Air
    13-inch late 2010
    2.13 ghz Intel Core 2 Duo
    4 gig memory

    The Screen shot is of the Midi setup.
  • Hey,

    Regarding the unknown error, we have noticed the issue and our developers have been notified about the same.

    Regarding the Sound flower issue, could you please elaborate your query?
  • Hallo, I've the same problem.
    Only screen recording without sounds work. I re-installed the soundflower but the problem is still the same. I'm using an old isight camera on a Mac Pro with OS X 10.8.2 and voila 3.3
    When do you think to have a fix for this?
  • Hi Conchology,

    Apologies that the temporary fix din't work out for you.
    We would like to inform you that we have been working on the issue and a fix has been provided. We will be providing with the update soon. Timeline for the update is highly unpredictable.
  • I'm having this problem as well. Changing the sample rate in Audio Midi Setup does not help. I can record computer audio, but when I try to record using USB mic it will not save file.

    I know I did a lot of this last year up until about May and it worked fine. So not sure if this is a problem with a Voila update or OS system update, but something seems to have changed since then.

    Noting that last post regarding this was in December, is there any update on this, or a way can go back to a previous version of Voila, since it seemed to be working fine then?
  • edited January 2013
    Hi Nynmr8r,

    We figured out that the problem is with the OS update. We have noted down this issue. It's taking a little bit of time to push an update and we appreciate your patience.
  • I have this problem too! Can you tell me how long do's it take to fix? please!
  • I suddenly have experienced the same problem {An unknown error has occurred while recording the video and the file cannot be saved to the disk(error code:-1)}
    Running MacOSX 10.7.5 and Voila 3.3 and a usb headset microphone {Andrea USB Digital}
    Had no problem before and just today the USB Mic will not work..I get the error code.
    I can get it to work with the built-in mic but get background noise.

    Admin in this post says they are working on a fix...I've tried most things posted here already with no success.
    Wat is next?
    Please advise
  • I am also having this issue. I just purchased the app and everytime I try and save, i get the error.
  • I'm working with the built-in mic, but that does record background sound and presents problems IF you do not have a sound booth. I also deleted the Soundflower app but it didn't help the USB mic problem.

    This is the first problems I've had with the program. For the most part it has been the best value in recording procedures...I teach and build my lectures this way.

    I just want my USB mic to work again!!!!!!
    I hope VOILA Tech support fixes this soon!
  • Hi Jcg,

    We have noted down this issue. It's taking a little bit of time for us to push an update and we appreciate your patience.
  • Thanks Admin,
    How come the USB mic worked for a short time then quit? and Why will it work on one computer (at work) and not in my studio? The setups are the same.
    Any other work-arounds you can suggest I try?
  • Hi Jcg,

    The issue is OS specific. Could you please let us know the OS configuration on two different Mac's?
  • Both are intel iMacs. The one that works fine is running OS 10.6.8
    The one that simply quite (meaning the USB mic did work but doesn't now is OS 10.7.5
    I do want you to know that the built-in mic works fine with 10.7.5 but the USB mic gives the error message.
    Now, question: Should I reinstall Voila on the OS 10.7.5? or wait for your response?
  • I get the same error message {An unknown error has occurred while recording the video and the file cannot be saved to the disk(error code:-1)} while trying to record full screen using the Mac mic.
    Any news on the update?
    The app is useless now.
  • I also just got the error message "An unknown error has occurred while recording the video and the file cannot be saved to the disk(error code:-1)". I do not know if it is related to this issue, but I got this message after using an USB mic for the first time. My OS is 10.7.5.
  • edited February 2013
    Regarding your query, you do not have to reinstall Voila in OS 10.7.5.
    This is a known issue (OS specific) and our developers have fixed the issue. Upcoming update of Voila will include the fixes and also we are working on few new features for Voila. Hence it might take some time for us to push an update.

    @beni22, @Willy,
    The issue has been fixed. Upcoming update of Voila will include the fixes. Until the next update, please make use of the Built-In mic to screen record.

    Thank you for co-operating.
  • I do have one more question: I have several logins on my Mac (as I assume many folks do). I usually have ONLY ONE login activated at one time. I noticed that I can use Voila on only the original login. When I launch it on another login ( that being the only active login at the time) it tells me to re-entter the activation key. Now is this normal? Will re-entering the activation key disrupt anything? Some advice on working through this type of situation would be greatly appreciated.

    And thanks for working on the update...I have no problem working with the built-in mic until you send out the update.

    Look forward to your additional help.
  • I just bought today and have the same problem.
    I'm using my Built-in Mic and getting this error.
  • I just read it's not going to be fixed until the next update?!! This is a bug that causes this program to not work. It's more than an update!
  • Hey JCG,

    Regarding your query, are you trying to open Voila app in different account? Voila is an account based application. You can use Voila only in one account.
    If you try to open Voila in different account then it will ask for the registration details.
    We are working on this and probably in future updates Boom will be a system wide application.
    Please go-ahead and register the other account.
  • Hey All,

    We would like to inform you that we have come up with the beta build where we have tried providing the fix for the issue you reported (where you were unable to save the screen recording).
    We are providing with a beta build so that you could download and verify if the issue you reported has been fixed. Please contact our Support Team for the beta build.
  • I'm having the same error. I'm using Mavericks and recording the screen video using the built-in mic. Any solution?
  • Hi DonDurrett,

    Could you please elaborate your query? Please provide us a sequence to regenerate the issue and few screenshots of the same. You can contact us directly via voila@globaldelight.com
This discussion has been closed.